summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmolith2024-02-16 15:43:32 -0500
committerAmolith2024-02-16 15:43:32 -0500
commitfa05c094b390c7294279683290a219d77fb81e49 (patch)
tree2837acd23a110e4db0df98d023756976bdebf381 /PKGBUILD
downloadaur-carpd-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..252c9b051c45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Amolith <amolith@secluded.site>
+pkgname=carpd-git
+_pkgname=${pkgname%-git}
+pkgdesc='Small tool that prints a count of total pending updates for Arch'
+arch=("any")
+url="https://git.sr.ht/~amolith/carpd"
+_branch='main'
+pkgver=r1.7aac36c
+pkgrel=1
+license=("Unlicense")
+makedepends=("git" "go")
+source=("$pkgname::git+$url#branch=$_branch")
+sha256sums=("SKIP")
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long --abbrev=7 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ )
+}
+
+build() {
+ cd $pkgname
+
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build -o "$_pkgname" .
+}
+
+check() {
+ cd "$pkgname"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 LICENSES/Unlicense.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}