summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcatppuccin2024-08-17 22:05:03 +0000
committercatppuccin2024-08-17 22:05:03 +0000
commit4ebb917f302de866e482484e485c295cbe6d6cf4 (patch)
treefccce780f4b9e7615ba901262b68bea3de00bfff /PKGBUILD
downloadaur-catppuccin-sddm-theme-frappe.tar.gz
Update PKGBUILD and .SRCINFO with GitHub Actions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb13adaf4b01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Catppuccin <releases@catppuccin.com>
+
+pkgname=catppuccin-sddm-theme-frappe
+pkgver=1.0.0 # renovate: datasource=github-tags depName=catppuccin/sddm
+pkgrel=1
+pkgdesc='Soothing pastel theme for SDDM - Frappe'
+arch=('any')
+license=('MIT')
+depends=('sddm' 'qt6-svg' 'qt6-declarative')
+url='https://github.com/catppuccin/sddm'
+source=(
+ "$pkgname-$pkgver.zip::$url/releases/download/v$pkgver/catppuccin-frappe.zip"
+)
+sha256sums=('6b7eb5e549e9a2bb28f7c6f8f42997bd55aaac172158aa2dcd780c2bfa262774')
+
+package() {
+ install -d "$pkgdir/usr/share/sddm/themes/"
+ cp -r -a --no-preserve=ownership \
+ catppuccin-frappe "$pkgdir/usr/share/sddm/themes"
+}