summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2023-09-03 14:30:05 -0400
committerPaul Hentschel (hpmachining)2023-09-03 14:30:05 -0400
commit5e07a261fdd77e8ef32df70c6744ef81180338ae (patch)
tree65d30d825d4d4f596c53618b11651e0a79da519e /PKGBUILD
parentdb1585e96715b6980d6c6552d997928c98d7d0ff (diff)
downloadaur-5e07a261fdd77e8ef32df70c6744ef81180338ae.tar.gz
Fixed packaging to add missing includes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b349da657a8..f9db3a81b7d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=r1519.58d2cb5c
+pkgver=r1552.2cbefd16
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -31,6 +31,8 @@ optdepends=(
)
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
+#_commit="58d2cb5cbce2e1d4e71cc7bbac65a49ddb6e40fe"
+#source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git#commit=$_commit"
source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git"
"0001_v8_sandbox_enable.patch")
sha256sums=('SKIP'
@@ -65,4 +67,5 @@ package() {
cp -a config/ "$pkgdir/opt/${pkgname%-git}/config/"
cp -a src/boost/boost/ "$pkgdir/opt/${pkgname%-git}/include/"
cp -a include/cbang/ "$pkgdir/opt/${pkgname%-git}/include/"
+ cp -a src/cbang/boost/ "$pkgdir/opt/${pkgname%-git}/include/cbang/"
}