summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Hentschel (hpmachining)2022-03-11 21:55:16 -0500
committerPaul Hentschel (hpmachining)2022-03-11 21:55:16 -0500
commit67777339dc0663011b1710a001f58648d6f9176a (patch)
tree3b7d7441b5a5738aa62a15cb66819a3fa862a2c5 /PKGBUILD
parent16cd7d353e05422ee0034cb1a7683145647eb842 (diff)
downloadaur-67777339dc0663011b1710a001f58648d6f9176a.tar.gz
Fixed pkgver() and check depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2abc09685f05..38835e3f288a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=1.6.0.r134.g18f1e963
+pkgver=r1345.38c036a1
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -24,6 +24,7 @@ makedepends=(
)
checkdepends=(
'python2'
+ 'python2-six'
)
optdepends=(
'mariadb-libs: MariaDB database support'
@@ -35,7 +36,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {