summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhpmachining2023-04-16 20:23:09 -0400
committerhpmachining2023-04-16 20:27:03 -0400
commit732c432b9c1e6891c9f6bae0634a8988e2a38ba3 (patch)
treedfa2a703dce10b56f8094bd6ea27857e3a45def8 /PKGBUILD
parent000aa673267ceb30bb7eb306e60e05a624e304e8 (diff)
downloadaur-732c432b9c1e6891c9f6bae0634a8988e2a38ba3.tar.gz
Added patch to enable v8 sandbox
Needed to fix runtime error with CAMotics
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aeda4efffe70..f20be91141ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: greyltc
pkgname=cbang-git
-pkgver=r1427.9b9f3b7d
+pkgver=r1485.ac8bbdd5
pkgrel=1
pkgdesc="A library of cross-platform C++ utilities"
arch=('x86_64')
@@ -31,14 +31,21 @@ optdepends=(
)
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
-source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/CauldronDevelopmentLLC/cbang.git"
+ "0001_v8_sandbox_enable.patch")
+sha256sums=('SKIP'
+ '75eff0bcd04293990f8dfb0771562356ccac2a7f40a06df0c0ba515fcdf4126a')
pkgver() {
cd "${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${pkgname%-git}"
+ patch -p1 -i "../0001_v8_sandbox_enable.patch"
+}
+
build() {
cd "${pkgname%-git}"
scons cxxstd="c++17" disable_local="libevent sqlite3 re2 libyaml zlib bzip2 expat"