summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2017-01-26 19:01:04 +0000
committerGrey Christoforo2017-01-26 19:01:04 +0000
commitcee2ad52f7bbf33801cfebd272f4d24d6569b27d (patch)
tree4981b5d55e4027b7e5a6026cd274d30a3a00469e /PKGBUILD
downloadaur-cee2ad52f7bbf33801cfebd272f4d24d6569b27d.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75e534f62d85
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=cbang-git
+pkgver=1.0.1.r229.g3335df9
+pkgrel=1
+pkgdesc="a library of cross-platform C++ utilities"
+arch=('any')
+url="https://github.com/CauldronDevelopmentLLC/cbang.git"
+license=('GNU GPL v2.1')
+depends=('scons'
+ 'boost-libs'
+ 'openssl'
+ 'libmariadbclient')
+source=("git+https://github.com/CauldronDevelopmentLLC/cbang")
+md5sums=('SKIP')
+
+pkgver() {
+ cd cbang
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd cbang
+ scons
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr
+ cp -a ${srcdir}/cbang/lib ${pkgdir}/usr/
+}
+