summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreomanis2023-09-25 00:14:39 +0200
committereomanis2023-09-25 00:14:39 +0200
commita8fa2a32fa7316301020d8ed2e45d122ffc91c55 (patch)
treee6810f7d0cee698c3e98d4b30f333db61bb7191e /PKGBUILD
downloadaur-certbot-dns-duckdns.tar.gz
Initial commit, certbot-dns-duckdns-1.3.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b268acd6ba6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# shellcheck shell=bash
+# shellcheck disable=SC2034 # Various variables that are used by makepkg
+# shellcheck disable=SC2154 # Various variables that are provided by makepkg
+# Maintainer: eomanis at web dot de
+
+pkgname='certbot-dns-duckdns'
+_pkgverUpstream="1.3"
+pkgver="1.3.0"
+pkgrel=1
+pkgdesc="Plugin for certbot for a DNS-01 challenge with a DuckDNS domain"
+arch=('any')
+url='https://github.com/infinityofspace/certbot_dns_duckdns'
+license=('MIT')
+depends=('certbot' 'python-dnspython' 'python-requests')
+makedepends=( 'python-build' 'python-installer' 'python-wheel' )
+source=("https://github.com/infinityofspace/certbot_dns_duckdns/archive/refs/tags/v${_pkgverUpstream}.tar.gz")
+sha256sums=('1faa4ebfb4902056dd90d45f8544a925d81ce8df34ab5d232acfb97e1bf12848')
+
+build() {
+ local srcRootDir="${srcdir}/certbot_dns_duckdns-${_pkgverUpstream}"
+ cd "$srcRootDir" || return 1
+
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ local srcRootDir="${srcdir}/certbot_dns_duckdns-${_pkgverUpstream}"
+ cd "$srcRootDir" || return 1
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}