summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-05-13 13:35:11 +0800
committerzxp198210052024-05-13 13:35:11 +0800
commite87aa1f9bcacfe407002df2e9e8c5d629328c340 (patch)
treebdea0b89da4d1cbee32434c4eb738355f446a6f5 /PKGBUILD
parent19fe9cfd64f7c54a1ded966a380433702eb0fe79 (diff)
downloadaur-chain-desktop-wallet-bin.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5b93f2f6b5c..b2a6c0779718 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=chain-desktop-wallet-bin
_appname="Crypto.com-DeFi-Desktop-Wallet"
pkgver=1.5.0
_electronversion=19
-pkgrel=1
+pkgrel=2
pkgdesc="Crypto.com DeFi Desktop Wallet"
arch=('x86_64')
url="https://crypto.com/defi-wallet"
@@ -12,7 +12,7 @@ license=("Apache-2.0")
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
- "electron${_electronversion}-bin"
+ "electron${_electronversion}"
)
makedepends=(
'fuse2'
@@ -22,11 +22,12 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4769a940ff0c46852a2cf0ca2f1c87f8234d8ecb40a1f35e8a5896bda35ad818'
- 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+ '41b6d61dffef064762b3eec3dfeca7a3e1f57cbcb6dce9a6940c06797a0eae9d')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@cfgdirname@|${pkgname%-bin}|g" \
-e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"