summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052025-05-15 16:57:06 +0800
committerzxp198210052025-05-15 16:57:06 +0800
commit1166ee4673471f683319ef684df8fb22f969b317 (patch)
treedf26a2888eca489eb861c5f1327679e6e4fbb25a /PKGBUILD
parenta15b10b4932fbb8d061e392397a74b8af9db6e63 (diff)
downloadaur-chatnio-bin.tar.gz
update to fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63e0cd7208d8..b051f043f251 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=chatnio-bin
-_pkgname="Chat Nio"
+_pkgname='Chat Nio'
pkgver=3.10
-pkgrel=2
+pkgrel=3
pkgdesc="🚀 Next Generation AI One-Stop Internationalization Solution.(Prebuilt version)"
arch=('x86_64')
url="https://coai.dev"
@@ -20,10 +20,10 @@ source=(
sha256sums=('4338657fce74a5bfcac3252a38058638c7327c084c627c81ae4203c8638f4d0d')
prepare() {
bsdtar -xf "${srcdir}/data."*
- sed -e "
+ sed -i -e "
s/Name=${pkgname%-bin}/Name=${_pkgname}/g
s/Categories=Development/Categories=Utility;/g
- " -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ " "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"