summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom van Dijk2021-12-30 19:05:53 +0100
committerTom van Dijk2022-01-22 13:25:46 +0100
commit623f5b3356c794dee7e0370e1785e1694746bfc6 (patch)
tree8c786d478480c1d770405bcb5aaee1604c887ac3 /PKGBUILD
downloadaur-chatterino2-dankerino-bin.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7e73319677cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: dtomvan <18gatenmaker6 at gmail dot com>
+
+_appimage="Chatterino-x86_64.AppImage"
+_pkgname='chatterino'
+pkgname="${_pkgname}2-dankerino-bin"
+pkgdesc="Dankerino is a fork of Chatterino 2."
+pkgver=608965e
+pkgrel=1
+depends=('qt5-multimedia' 'qt5-base' 'qt5-tools' 'qt5-imageformats' 'boost-libs' 'openssl')
+optdepends=('streamlink: For piping streams to video players'
+ 'pulseaudio: For audio output'
+ 'gst-plugins-good: For audio output')
+arch=('x86_64')
+url="https://github.com/Mm2PL/dankerino/"
+license=('MIT')
+provides=(${_pkgname})
+options=(!strip)
+conflicts=(
+ 'chatterino2-git'
+ 'chatterino2-appimage'
+ 'chatterino2-nightly-appimage'
+ 'chatterino2-7tv-git'
+ 'chatterino2-dankerino-git'
+)
+source=(
+ https://github.com/Mm2PL/dankerino/releases/download/nightly-build/$_appimage
+)
+
+sha256sums=(
+ SKIP
+)
+
+prepare () {
+ cd "$srcdir"
+ chmod +x $_appimage
+ ./$_appimage --appimage-extract
+}
+
+package() {
+ cd "$srcdir"
+
+ install -Dm755 ../$_appimage "$pkgdir/opt/chatterino/$_appimage"
+ install -dm755 "$pkgdir/usr/bin"
+
+ ln -s "/opt/chatterino/$_appimage" "$pkgdir/usr/bin/chatterino"
+
+ install -Dm644 "squashfs-root/com.chatterino.chatterino.desktop" "$pkgdir/usr/share/applications/com.chatterino.chatterino.desktop"
+ install -Dm644 "squashfs-root/chatterino.png" "$pkgdir/usr/share/pixmaps/chatterino.png"
+}