summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMilkii Brewster2021-11-22 02:39:48 +0000
committerMilkii Brewster2021-11-22 02:39:48 +0000
commitf87efc1b16c4c57c0ad653c90463c09749a90e7b (patch)
treeafd81e871b95ef972bcc694de783c564e8c988d5 /PKGBUILD
parente1d9722a26bac14127d5385aa51c3bb0c0b1df41 (diff)
downloadaur-chowtapemodel.lv2-git.tar.gz
fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35385683bc9d..9a5fb5f5130f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
maintaner="Milkii Brewster <milkii on Freenode IRC>"
pkgname=chowtapemodel.lv2-git
pkgdesc="Physical modelling signal processing for analog tape recording."
-pkgver=r165.7aebad0
+pkgver=r258.d5b3109
pkgrel=1
arch=(x86_64)
url="https://github.com/jatinchowdhury18/AnalogTapeModel"
@@ -12,12 +12,8 @@ conflicts=('chowtapemodel.lv2' 'chowtapemodel.lv2-bin')
provides=('chowtapemodel.lv2' 'chowtapemodel.lv2-bin')
depends=('git' 'alsa-lib' 'libxcursor' 'libxinerama' 'libxrandr' 'freeglut' 'jack' 'xsimd')
makedepends=()
-source=("$pkgname::git+https://github.com/jatinchowdhury18/AnalogTapeModel"
- "git+https://github.com/jatinchowdhury18/JUCE.git"
- "git+https://github.com/ffAudio/foleys_gui_magic.git")
-md5sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=("$pkgname::git+https://github.com/jatinchowdhury18/AnalogTapeModel")
+md5sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -32,11 +28,11 @@ prepare() {
# rm -rf Plugin/Juce
# rm -rf Plugin/foleys_gui_magic
- git submodule init
- git config submodule.Plugin/Juce.url "${srcdir}"/JUCE
- git config submodule.Plugin/foleys_gui_magic.url "${srcdir}"/foleys_gui_magic
- git submodule sync --recursive
- git submodule update
+ # git config submodule.Plugin/Juce.url "${srcdir}"/JUCE
+ # git config submodule.Plugin/foleys_gui_magic.url "${srcdir}"/foleys_gui_magic
+ git submodule update --init --recursive
+ # git submodule sync --recursive
+ # git submodule update
rm -rf Juce/VST2_SDK
}