summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJavier Torres2018-06-03 10:43:56 +0200
committerJavier Torres2018-06-03 10:43:56 +0200
commit0af693fe6cc8e49851582f834d4ed9b266e8c25c (patch)
tree6b2e8fb070d9b366ec89ea40c0bbfa4c71cff33f /PKGBUILD
parentd620c57096d33ef73bf71d54481d3f81d2247b6a (diff)
downloadaur-chwala.tar.gz
PHP 8 compatibility
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bdac7d1593a7..7e3afcd4e3ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,32 @@
# Maintainer: Javier Torres <javitonino [at] gmail [dot] com>
pkgname=chwala
pkgver=0.3.1
-pkgrel=2
+pkgrel=3
pkgdesc='Kolab File Management'
arch=('any')
license=('AGPL3')
makedepends=()
-depends=('php-mcrypt' 'pear-http-request2' 'roundcubemail' 'smarty3' 'php-kolabformat')
+depends=('pear-http-request2' 'roundcubemail' 'smarty3' 'php-kolabformat')
url='http://kolab.org'
install=chwala.install
#backup=()
source=("https://mirror.kolabenterprise.com/pub/releases/${pkgname}-${pkgver}.tar.gz"
"chwala.install"
"chwala.tmpfiles"
- "apache.patch")
+ "apache.patch"
+ "php8.patch")
#optdepends=()
sha256sums=('e2de71bbced0910ba3561323e1d8d5aafc8f09d8d27f5bdc36546b701c1a29b8'
'63c6661fe031f001357ffbecaed8bcd9f1d56549d5223c89e583713cc01d9e51'
'e88b39da4157a2ff99e692d771b10c496ab1122f240d72db0a2c8bcacdfcf09b'
- 'd41a6b0eefdc7e5a4b134813bc772644e462eb7b768f2f18bd28aae9d169cfb6')
+ 'd41a6b0eefdc7e5a4b134813bc772644e462eb7b768f2f18bd28aae9d169cfb6'
+ '68d3cce39cc83e50d4baa1eba87b6e04964bdd5b55fc204d91bf9f7cf8952d15')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 < "${srcdir}/apache.patch"
+ patch -p1 < "${srcdir}/php8.patch"
}
package() {