summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Birks2019-01-23 12:11:52 -0500
committerDavid Birks2019-01-23 12:11:52 -0500
commit45190de286b4c6ec305ada99db05eee83b16104b (patch)
treedc18881c1080391af39f668879cf22539075263c /PKGBUILD
downloadaur-cinf.tar.gz
Added v0.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ad0a5b83793
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: David Birks <david@tellus.space>
+
+pkgname=cinf
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Command line tool to view namespaces and cgroups'
+arch=('x86_64')
+url="https://github.com/mhausenblas/cinf"
+license=('Apache')
+makedepends=('go')
+source=("$url/archive/v$pkgver-alpha.tar.gz")
+sha512sums=('bd73ed979c1456de51f934257b7071e7fa3a8ae6466800c37c3f84b3c95f69fc9b8989e906831c452cca9e78139a98a9e3152656b8e513aec0619408b81ba43c')
+
+prepare(){
+ mkdir -p gopath/src/github.com/mhausenblas/
+ ln -rTsf $pkgname-$pkgver-alpha gopath/src/github.com/mhausenblas/cinf
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/mhausenblas/cinf
+ go get -d ./...
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd gopath/src/github.com/mhausenblas/cinf
+ go install \
+ -gcflags "all=-trimpath=$GOPATH" \
+ -asmflags "all=-trimpath=$GOPATH" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v ./...
+}
+
+package() {
+ install -Dm755 gopath/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+