summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-05-13 00:19:02 +0000
committerGeorge Rawlinson2022-05-13 00:19:02 +0000
commit101da7e151020dba393f202e5d7157d4342fa799 (patch)
treedeb0677ddfb9db04a5d1309442248bb9327731a3 /PKGBUILD
parentded1a76719e05717af3099b76fb059ac841706f5 (diff)
downloadaur-cl-bordeaux-threads.tar.gz
upgpkg: cl-bordeaux-threads 0.8.8-4
* Add missing dependencies. * Add tests and related dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 22 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1a2d4d3b226..255f8b1427d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,21 @@
pkgname=cl-bordeaux-threads
_pkgname="${pkgname#cl-}"
pkgver=0.8.8
-pkgrel=3
+pkgrel=4
pkgdesc='Portable shared-state concurrency for Common Lisp'
arch=('any')
url='https://sionescu.github.io/bordeaux-threads/'
license=('MIT')
-depends=('common-lisp' 'cl-asdf' 'cl-alexandria')
+depends=(
+ 'common-lisp'
+ 'cl-asdf'
+ 'cl-alexandria'
+ 'cl-global-vars'
+ 'cl-trivial-features'
+ 'cl-trivial-garbage'
+)
makedepends=('git' 'sbcl')
+checkdepends=('cl-fiveam')
_commit='076fe2380abbc59b06e495dc7a35aea8eb26ba3b'
source=("$pkgname::git+https://github.com/sionescu/bordeaux-threads#commit=$_commit")
md5sums=('SKIP')
@@ -21,6 +29,18 @@ pkgver() {
git describe --tags | sed -e 's/^v//' -e 's/-/.r/' -e 's/-/./g'
}
+check() {
+ cd "$pkgname"
+
+ sbcl \
+ --eval '(require "asdf")' \
+ --eval '(push (uiop/os:getcwd) asdf:*central-registry*)' \
+ --eval '(asdf:load-system "bordeaux-threads/test")' \
+ --eval '(asdf:load-system "fiveam")' \
+ --eval '(unless (fiveam:run :bordeaux-threads) (uiop:quit 1))' \
+ --quit
+}
+
package() {
cd "$pkgname"