summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2024-02-06 12:52:21 -0300
committerRafael Fontenelle2024-02-06 12:52:21 -0300
commit2636e6a75840b59c596a636a450de5ff3dc6f4c7 (patch)
tree50558f2a36f543e3547773095343c37be9b6bc4d /PKGBUILD
downloadaur-classified-ads.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fcb641ce773c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: rafaelff <rafaelff@gnome.org>
+
+pkgname=classified-ads
+pkgver=0.16
+pkgrel=1
+pkgdesc="A distributed, server-less messaging system"
+arch=('x86_64')
+url="http://katiska.org/classified_ads/"
+license=('LGPL-2.1-or-later')
+depends=(qt5-multimedia miniupnpc tk libnatpmp)
+makedepends=(imagemagick)
+source=("https://github.com/operatornormal/$pkgname/archive/$pkgver.tar.gz#/$pkgname-$pkgver.tar.gz")
+sha256sums=('01a0a5cf470297147303c86b2b9f5c1a8eb5c6b183ee496373919b6790fc1592')
+
+build() {
+ cd $pkgname-$pkgver
+ make -C graphics-highres
+ qmake-qt5 PREFIX=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make INSTALL_ROOT="$pkgdir" DESTDIR="$pkgdir" install
+}