summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Daum2024-04-16 13:39:38 +0200
committerAlexander Daum2024-04-16 13:39:38 +0200
commit08e4f62f1dad6006946b9f6895245e0d6cc0e736 (patch)
tree7738f2f16f7004bbb9103aa38743544cc9394051 /PKGBUILD
parent6222d47209c4f3f4a38d3113b376a2df81b2bf37 (diff)
downloadaur-coco_r_cpp.tar.gz
Correctly include license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aeb1734d9925..e769e977229a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
pkgname='coco_r_cpp'
pkgver=2018_12_03
-pkgrel=1
+pkgrel=2
pkgdesc='Coco/R Compiler Generator (C++ version)'
url='https://ssw.jku.at/Research/Projects/Coco/'
license=(
- 'custom' # TODO install license
+ 'custom'
)
source=(
"https://ssw.jku.at/Research/Projects/Coco/CPP/CocoSourcesCPP.zip"
+ "https://ssw.jku.at/Research/Projects/Coco/Doc/license.txt"
)
sha512sums=(
'97baa9ac9888785562d1e2bd56fb433a3abdc037b9ea05382c7a85f1d3bb9f3da0a120e9bac2798da84207ebd66590b9ab08db57c2df4ed4968ac2a200285003'
+ '9eaa22aa4a7404285e1c93ece5e4439b3c9a53c7e86a084063b299f373090c1e1e1800b82fc49c131e34d37665e5161d560bd65a496d12d1b944d4b0ed6212bf'
)
arch=(
'x86_64'
@@ -27,4 +29,5 @@ package() {
install -D -m 0755 Coco ${pkgdir}/usr/bin/cococpp
install -d ${pkgdir}/usr/share/coco-cpp/
install -m 0644 *frame ${pkgdir}/usr/share/coco-cpp/
+ install -Dm644 'license.txt' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}