summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYour Name2020-12-17 17:11:39 +0800
committerYour Name2020-12-17 17:11:39 +0800
commit87d94b0039e6ca5b509d8a9f57c90b7aaa6d6f24 (patch)
tree296a4710fd280f938634ee1ea795f28fb8f3648b /PKGBUILD
downloadaur-com.eastmoney.emdesk.deepin.tar.gz
Pack com.eastmoney.emdesk.deepin
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..bdd7e714476b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=com.eastmoney.emdesk.deepin
+pkgver=9.4.0.9142
+pkgrel=3
+epoch=
+pkgdesc="EastMoney Client on Deepin Wine"
+arch=('i686' 'x86_64')
+url="https://www.eastmoney.com/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5-stable>=5.0.0.16' 'deepin-wine-helper' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=eastmoney.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('81c812d0321e7a5e8026f4cb204c726132b1ed4cf1cbe5d2b32319bc81dfc80cd9b0c2addab56308f2fde2393d4d30664c49192bc5229721a0a72a6c8e5875c9')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}