summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjose17112018-06-25 13:25:28 +0200
committerjose17112018-06-25 13:25:28 +0200
commit6abc2df19ce62de97d8a54f85a4f2736a83dfb98 (patch)
tree15455881c741d2eafcf95229ea42a8659405eed2 /PKGBUILD
downloadaur-compleat-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de2dd376ecbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=compleat-git
+_pkgname=compleat
+pkgver=r119.4923685
+pkgrel=1
+pkgdesc="Bash completion for human being"
+url="https://limpet.net/mbrubeck/2009/10/30/compleat.html"
+license=("custom")
+makedepends=('stack')
+arch=('any')
+source=("${_pkgname}"::'git+https://github.com/mbrubeck/compleat.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/{bin,share/doc/$_pkgname/examples}
+ cd "$srcdir/${_pkgname}"
+ stack install --local-bin-path=${pkgdir}/usr/bin/
+ install -Dm644 compleat_setup ${pkgdir}/etc/bash_completion.d/compleat_setup
+ install -Dm644 examples/* ${pkgdir}/usr/share/doc/$_pkgname/examples
+ install -Dm644 README.markdown ${pkgdir}/usr/share/doc/$_pkgname
+}