summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartoko2021-07-16 18:50:17 +0200
committerMartoko2021-07-16 18:50:17 +0200
commit21802735f955c7959e8b93c8c9d30f8b980ef495 (patch)
tree11c88b9d52411fee8664d12b33f4689feb37b9dd /PKGBUILD
downloadaur-concordium-node-bin.tar.gz
Inital commit with v1.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdb5061ee0dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Martoko <mbastholm at gmail dot com>
+
+pkgname=concordium-node-bin
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Node for the Concordium blockchain"
+arch=('x86_64')
+url="https://github.com/Concordium/concordium-node"
+license=('AGPL3')
+depends=('postgresql-libs' 'openssl' 'unbound')
+install=concordium-node-bin.install
+source=("https://distribution.mainnet.concordium.software/deb/concordium-node_${pkgver}-mainnet_amd64.deb")
+sha256sums=('dcb76543e4fb0346242df1d8873bbdf89af6ccbd49ea6b4d315bd1dc4c14a135')
+
+package() {
+ tar xf data.tar.xz -C "${pkgdir}"
+ rm -r "${pkgdir}/usr/share" # Delete changelog.Debian.gz
+ mv "${pkgdir}/lib" "${pkgdir}/usr"
+}