summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Vilar Benet2023-08-22 01:45:17 +0200
committerDavid Vilar Benet2023-08-22 01:45:17 +0200
commita8665d9bf1cb66954bdaf407f746d044cdd78075 (patch)
tree026f8831890f2b12b732992653e4e128464b8bae /PKGBUILD
downloadaur-cookiemonster.tar.gz
initial commit version 1.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80fc41147045
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: dvb <archlinux at b0rken dot de>
+
+pkgname=cookiemonster
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Tool for decoding and modifying vulnerable session cookies from several different frameworks."
+arch=('x86_64')
+url="https://github.com/iangcarroll/cookiemonster/"
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+provides=('cookiemonster')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha512sums=('440502b16d8a5d92379121fca85d8a598f30bd5ef8bf950433c0b51cc890ad03e1c4ceb55466ae48741c880c371d6578b1695fb56c7c9fe3dfa43864b72201c6')
+
+build() {
+ cd "$pkgname-$pkgver/cmd/$pkgname"
+ GOPATH="$srcdir/$pkgname-$pkgver/cmd/$pkgname" go build -buildmode=pie -ldflags "-linkmode=external -extldflags=$LDFLAGS" -modcacherw -trimpath
+}
+
+package() {
+ install -Dm644 "$pkgname-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
+ install -Dm755 "$pkgname-$pkgver/cmd/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}