summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDasith Gunawardhana2018-03-22 00:00:57 -0400
committerDasith Gunawardhana2018-03-22 00:00:57 -0400
commit829c1749cbe0a903185859f445eef1305b9a54ac (patch)
tree3ad519728b5358b82883c4c2783c2805f3bb8610 /PKGBUILD
downloadaur-copac-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..145091bd494b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dasith Gunawardhana <dasith.gunawardhana@gmail.com>
+
+_pkgname=copac
+pkgname=${_pkgname}-git
+pkgver=r7.58838f2
+pkgrel=1
+pkgdesc="An AUR helper"
+arch=('x86_64')
+url="https://gitlab.com/dasith.gunawardhana/copac.git"
+license=('GPL3')
+depends=('pacman' 'libgit2' 'curl')
+makedepends=('git' 'nlohmann-json')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=('git+https://gitlab.com/dasith.gunawardhana/copac.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}