summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAditya Saligrama2017-11-03 19:20:12 -0400
committerAditya Saligrama2017-11-03 19:20:12 -0400
commit31ff2b56de74b2e0f6e8fe1e90dcc6e1dcfbb600 (patch)
tree0003787a1847649c3953c115592fc591c6fc041e /PKGBUILD
downloadaur-corels.tar.gz
initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3eea9769fe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Aditya Saligrama <saligrama427@gmail.com>
+pkgname=corels
+pkgver=1.0
+pkgrel=1
+pkgdesc="Certifiably Optimal Rule Lists. C-library to build a certifiably optimal rule list from input data and labels."
+arch=('i686' 'x86_64')
+url="https://github.com/nlarusstone/corels"
+license=('GPL')
+groups=()
+depends=('gsl' 'gmp')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/margoseltzer/corels-homebrew/files/1441466/corels-1.0.tar.gz")
+noextract=()
+sha256sums=("013fd81472759a4e8f7ae8dec9ce4a9769286d41cd3ff33c5fc9bfb668a70b7d")
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}