summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2023-09-21 14:38:58 +0200
committerMarco Rubin2023-09-21 14:38:58 +0200
commite8b764fd1b3abd943e4e883b3ef800be104fece0 (patch)
treedfd73662260b3aa5a876f7438fbe92d99f17fb76 /PKGBUILD
parentec15b6d8f39ba8421c96b27aa0975df6ef1d62a3 (diff)
downloadaur-cpu-git.tar.gz
20230915
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be89efb880b6..b6f877b7b577 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,34 @@
_pkgname=cpu
pkgname=$_pkgname-git
-pkgver=20230813
+pkgver=20230915
pkgrel=1
pkgdesc='cpu command in Go, inspired by the Plan 9 cpu command'
arch=('any')
license=('BSD')
makedepends=(git go)
url='https://github.com/u-root/cpu'
-source=("git+$url#commit=ef9e255c23f2205bce9e4d55380aabd2071461e9")
+source=("git+$url#commit=c34f1ddc32533aaaebf829584d915a2e98f9ba39")
b2sums=('SKIP')
prepare() {
- cd "$_pkgname"
+ cd $_pkgname
mkdir -p build
}
build() {
- cd "$_pkgname"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
+ cd $_pkgname
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_LDFLAGS="$LDFLAGS"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o build ./...
}
package() {
- cd "$_pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ cd $_pkgname
install -Dm755 build/cpu "$pkgdir"/usr/bin/cpu
install -Dm755 build/cpud "$pkgdir"/usr/bin/cpud
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}