summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2018-07-23 16:17:52 -0400
committerJean Lucas2018-07-23 16:17:55 -0400
commit6bc0929b207622fac3c94cb1c5173a81b6725010 (patch)
tree6fb82f7570fbb8fdfe64b6d574fa54f5b2bb8546 /PKGBUILD
parentae24040c164cddfd9702652096cb768efeb47e04 (diff)
downloadaur-cryptocat-bin.tar.gz
Omit desktop file and pixmap installations
User is prompted for their installation by the binary on every run.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcdefb38d77f..f3a0f2b29b9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=cryptocat-bin
pkgver=3.2.08
-pkgrel=1
-pkgdesc='Secure chat client based on Electron (bin)'
+pkgrel=2
+pkgdesc='Encrypted chat client based on Electron (bin)'
arch=(x86_64)
url=https://crypto.cat
license=(GPL3)
depends=(glib2 fuse2 gconf)
-makedepends=(gendesk gnupg)
+makedepends=(gnupg)
provides=(cryptocat)
conflicts=(cryptocat)
options=(!strip)
@@ -18,13 +18,8 @@ sha512sums=(6bdb8d23bb1ab4b2706437806da770486001315b79956ee5939960af3eb3074b8204
prepare() {
msg2 'Run `gpg --recv-keys AB266CB76091B1F8` for GPG verification to work'
gpg --verify Cryptocat.AppImage.asc Cryptocat.AppImage
- gendesk -f -n --pkgname cryptocat --pkgdesc "$pkgdesc"
- bsdtar --to-stdout -xf Cryptocat.AppImage \
- usr/share/icons/default/64x64/apps/cryptocat.png > cryptocat.png
}
package() {
install -D Cryptocat.AppImage $pkgdir/usr/bin/cryptocat
- install -Dm 644 cryptocat.desktop $pkgdir/usr/share/applications/cryptocat.desktop
- install -Dm 644 cryptocat.png $pkgdir/usr/share/pixmaps/cryptocat.png
}