summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMárton Szabó2017-12-28 16:13:32 +0100
committerMárton Szabó2017-12-28 16:13:32 +0100
commit6f993f77ff954ca3a4c49f14556ebdeee4eb6dc9 (patch)
tree06c9eb9e80b997a2cef4fc6fd6171517de58267a /PKGBUILD
parent753aca2ffddb0a4bfa2fa3fd360e9bcf6eb1425d (diff)
downloadaur-crystal-icr-git.tar.gz
corrected pkgver()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c588f114e7c..06acd8677f31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Márton Szabó <username="notramo" host="vipmail.hu">
pkgname=crystal-icr-git
-pkgver=0.4.0
+pkgver=v0.4.0.r5.4495b1d
pkgrel=1
pkgdesc="Interactive console for Crystal programming language. Git version."
arch=(i686 x86_64)
@@ -11,14 +11,14 @@ makedepends=('llvm')
source=("git+https://github.com/crystal-community/icr")
sha256sums=('SKIP')
-build() {
+pkgver() {
cd "icr"
- make
+ printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
-check() {
+build() {
cd "icr"
- make test
+ make
}
package() {