summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Hiles2017-08-15 14:13:16 -0400
committerMatthew Hiles2017-08-15 14:13:16 -0400
commitb0942c80d634a02b17824768a09c965f703e6aff (patch)
tree30eaa76448e2c42dc8d09a61fe5520944f20f8e8 /PKGBUILD
downloadaur-ctk.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fde46975d165
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Matthew Hiles <matthew.hiles@gmail.com>
+# Contributor: Jeffrey David Johnson <jefdaj@gmail.com>
+
+pkgname=ctk
+pkgver=8.0.4001
+pkgrel=1
+pkgdesc="A Curses implementation of Tk / Make your Tk apps CUI apps"
+url="http://rkeene.org/devel/ctk/"
+depends=(tcl ncurses)
+arch=(any)
+license=("MIT")
+options=()
+source=(http://rkeene.org/devel/ctk/$pkgname-$pkgver.tar.gz)
+md5sums=('3d2746f499cf0d2158dfbedfad0afc47')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+} \ No newline at end of file