summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-01 21:03:52 +0000
committerBioArchLinuxBot2023-06-01 21:03:52 +0000
commitf87a93a8f4fa1bbc50bdfdb0ef5a9efca6a47a5d (patch)
tree93d7da88da9d290828b863b832412647e4bfbcbd /PKGBUILD
parent19f3c3d1d0772abad9e993b27e59f53bd4a478b8 (diff)
downloadaur-cufflinks.tar.gz
[lilac] updated to 2.2.2.20190706.162801-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 35 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a364566836a..dab02ecb5cc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,48 @@
-# Maintainer: Grey Christoforo <first name @ last name .net>
+# Maintainer: Guoyi Zhang <myname at malacology dot net>
+# Contributor: Charles E. Vejnar <ce@vejnar.org>
pkgname=cufflinks
-pkgver=2.2.1
-pkgrel=5
-pkgdesc="Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples.."
+_realname=cufflinks
+pkgver=2.2.2.20190706.162801
+pkgrel=2
+pkgdesc="Transcriptome assembly and differential expression analysis for RNA-Seq."
+url="http://cole-trapnell-lab.github.io/cufflinks/"
arch=("x86_64")
-url="http://cole-trapnell-lab.github.io/projects/cufflinks/"
-license=('Artistic')
-depends=('boost' 'eigen3' 'python2' 'samtools' 'perl')
-source=(https://github.com/cole-trapnell-lab/${pkgname}/archive/v${pkgver}.tar.gz)
-md5sums=('80328ff4169f2778c0728a4795da85e2')
+license=("BSL")
+depends=('python' 'htslib' 'boost-libs')
+makedepends=('autoconf' 'make' 'ncurses' 'boost' 'eigen' 'git' 'samtools' 'htslib')
+source=("git+https://github.com/cole-trapnell-lab/cufflinks.git"
+ "$pkgname.patch::https://github.com/cole-trapnell-lab/cufflinks/pull/108.patch")
+sha1sums=('SKIP'
+ '081021851cfcc0372bcf1f2e56aa11d0a3b5862c')
+pkgver () {
+ cd "$srcdir/$pkgname"
+ printf "$(cat configure.ac | grep 'AC_INIT' | sed "s@\[@@g;s@\]@@g;s@,@@g" | awk '{print $2}').%s" "$(TZ=UTC git log -1 --pretty='%cd' --date=format-local:%Y%m%d.%H%M%S)"
+}
prepare() {
- cd $srcdir/$pkgname-$pkgver
-
- sed -i 's,hash\[pos\]\.hash,(hash[pos].hash),g' src/GHash.hh
-
- curl -L https://github.com/cole-trapnell-lab/cufflinks/commit/305ee7ba4fa8e8df095d293b9e0827c6a85679a8.patch | patch -p1
- curl -L https://github.com/cole-trapnell-lab/cufflinks/commit/6c62baa6a9f3a00b71c8fc8f7f4059a7fe49824.patch | patch -p1
-
- curl -L https://github.com/cole-trapnell-lab/cufflinks/pull/87/commits/b7313fffc9d1e3dc92ce8a90b0dd5b2e16cfd68f.patch | patch -p1
-
- #curl -L https://github.com/cole-trapnell-lab/cufflinks/pull/108/commits/d1fdcfd1441d1a8c3b5ecaa1b60a4ae876350061.patch | patch -p1
- #curl -L https://github.com/cole-trapnell-lab/cufflinks/pull/108/commits/80219fc315208adb4941a20701d68c25f56db756.patch | patch -p1
-
- curl -L https://github.com/cole-trapnell-lab/cufflinks/pull/107/commits/7aa2922ab1f4ff600bd6854cdebb4be6d3b06fa5.patch | patch -p1
-
- ./autogen.sh
- # cufflinks uses python2 but archlinux uses python3 as default python
- perl -i -pne '$_ =~ s/python/python2/ if $_ =~ /^#!\/usr/' src/cuffmerge
-
- export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
- export LDFLAGS="-L/usr/lib -lboost_system"
- ./configure --prefix=/usr
+ cd $srcdir/$pkgname
+# for 2.2.1
+# sed -i "16d" configure.ac
+# sed -i "s@bam/sam.h@htslib/sam.h@g" src/hits.h
+# sed -i "s@boost/tr1/unordered_map.hpp@boost/unordered_map.hpp@g" src/biascorrection.h
+ sed -i "17d" configure.ac
+ sed -i "s@sprintf((char \*)vdptr(vs),cmdline);@sprintf((char \*)vdptr(vs),\"%s\",cmdline);@g" src/locfit/makecmd.c
+ sed -i "s@int curwin;@extern int curwin;@g" src/locfit/startlf.c
+ patch -p1 < $srcdir/$pkgname.patch
}
build() {
- cd $srcdir/$pkgname-$pkgver
- export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
- export LDFLAGS="-L/usr/lib -lboost_system"
- make
+ cd $srcdir/$pkgname
+ autoreconf --install
+ ./configure --prefix=/usr --with-boost --with-eigen --with-bam \
+ LIBS="-lboost_system -lboost_thread -lboost_serialization"
+ make CXXFLAGS="-I/usr/include/eigen3 -I/usr/include/htslib/ -std=c++11 -lhts -lpthread"
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgname"
+ make install DESTDIR="$pkgdir"
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}