summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBartosz Bartczak2023-04-08 10:31:46 +0200
committerBartosz Bartczak2023-04-08 10:31:46 +0200
commitc10b24c023abd92643fd93bff416f7f235dde349 (patch)
treef4a59f87edbf6861f20fdcedbd462af180516d7a /PKGBUILD
parent2ea57786f12661ff9814ee5597e1c7348b022f50 (diff)
downloadaur-cura.tar.gz
added a new version 5.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 834772b87519..26c51038d567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Maintainer: batot <archpackager @ algrim . pl>
+# Contributor: Jelle van der Waa <jelle@archlinux.org>
# Contributor: Grey Christoforo <my first name [at] my last name [dot] net>
pkgname=cura
-pkgver=4.13.1
+pkgver=5.3.0
pkgrel=1
pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
depends=('python-pyqt5' 'qt5-svg' 'python-scipy' 'python-pyserial' 'python-numpy' 'uranium' 'python-requests'
@@ -21,18 +22,17 @@ license=('LGPL')
arch=('any')
source=($pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz
cura-${pkgver}-no-sentry.patch::https://github.com/Ultimaker/Cura/commit/aad41807c365ccef001b787407d7dc756e11de02.patch)
-sha512sums=('6483fd6312bd2181cc812bce78aadc7e8532ecf292f09c75ce5e7870f7efddd63e84315ab40eb73c775b15c2ed2ce7fc804fcbefb73b3d8aaac77d8b22f0cbd0'
+sha512sums=('79421486e89082a0b9f9435e778193f26d067c87fa52dbd277113da5614d5ce340d676aacdc1193bd2ab76de8c9456163bf983181d8d213e96b1af25b4a6b713'
'c602c5e585862d9bab280a8d5bd2289fe1b10d79f54cd76171b76fcf48793b190ff5bf6fca22818d8b65a726ee64098750c79cba67f044e0186a83aeb78e8a14')
# Build order
# arcus -> uranium -> curaengine -> libsavitar -> pynest2d ->
-prepare(){
- cd Cura-${pkgver}
- sed -i 's,/dist-packages,.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
-
- patch -Np1 -i $srcdir/cura-${pkgver}-no-sentry.patch
-}
+#prepare(){
+# cd $srcdir/Cura-${pkgver}
+# sed -i 's,/dist-packages,.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
+# patch -Np1 -i $srcdir/cura-${pkgver}-no-sentry.patch
+#}
build(){
cd Cura-${pkgver}
@@ -53,9 +53,9 @@ build(){
package(){
cd Cura-${pkgver}/build
make DESTDIR="${pkgdir}" install
-
+
# make sure cura can find uranium plugins:
- ln -s /usr/lib/uranium/plugins/* "${pkgdir}/usr/lib/cura/plugins/."
+ # ln -s /usr/lib/uranium/plugins/* "${pkgdir}/usr/lib/cura/plugins/."
# don't ever send any user or print info through the internet to Ultimaker
rm -rf "${pkgdir}/usr/lib/cura/plugins/SliceInfoPlugin"