summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2023-04-01 00:47:22 +0200
committerAntonio Rojas2023-04-01 00:47:22 +0200
commitb1e41a033556beb1d5055cfa32658bf901ac939c (patch)
tree334660b98fde9593a1183a82c4c5e6f5d3b1f2f6 /PKGBUILD
downloadaur-curseofwar.tar.gz
import from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1c582e7a50b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: ziggi <xziggix@gmail.com>
+
+pkgname=curseofwar
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Fast-paced RTS/Action game with ncurses interface'
+arch=('x86_64')
+url='https://github.com/a-nikolaev/curseofwar/wiki'
+license=('GPL')
+depends=('ncurses')
+makedepends=('gcc')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/a-nikolaev/curseofwar/archive/v$pkgver.tar.gz")
+sha512sums=('87d151af2a4eadbecd3f87867db8fb2277209e89a120443c9ee41065efc2004512f0b033626c2acddb98867eea6097c71b9aa7e4153f8b04b7b847682bc84705')
+
+build() {
+ make -C "$pkgname-$pkgver"
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: