summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhalbGefressen2020-12-13 13:27:58 +0100
committerhalbGefressen2020-12-13 13:27:58 +0100
commitc76b10bd1d9170f140f439e126a0d0b18f98d861 (patch)
treea6146b53a5998e7a558bb0b1524b10a4e5fa263b /PKGBUILD
downloadaur-cyp-lukasstevens-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61bc7a3f0f2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Christian Zimmerer <christian(DOT)zimmerer(AT)protonmail(DOT)com>
+pkgname=cyp-lukasstevens-git
+pkgver=r294.3129d6f
+pkgrel=1
+epoch=
+pkgdesc="(Check Your Proof) Checker for \"morally correct\" induction proofs about Haskell programs"
+arch=(x86_64 i686)
+url="https://github.com/lukasstevens/cyp"
+license=(MIT)
+groups=()
+depends=(gmp libffi)
+makedepends=(git ghc ghc-static stack)
+checkdepends=()
+optdepends=()
+provides=(cyp)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd cyp
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd cyp
+ stack build
+}
+
+check() {
+ cd cyp
+ stack test
+}
+
+package() {
+ cd cyp
+ stack install --local-bin-path $pkgdir/usr/bin
+ install -Dm644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}