summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorflan_suse2024-02-23 17:47:28 -0500
committerflan_suse2024-02-23 17:47:28 -0500
commite3245c505947f2fb7cd89d44e8d4a673592f856c (patch)
tree18aad2aec819180a47a7924d0bf2bb5d0261dba1 /PKGBUILD
parent2b71ff26507b4e81762d5673966332e595c674d8 (diff)
downloadaur-czkawka-gui-bin.tar.gz
Cleaned up PKGBUILD and sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0dcf9f79190b..677e8f327dff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=czkawka-gui-bin
pkgver=7.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Find and manage duplicate files, empty folders, similar images, and other "lint" (GUI, with HEIF support)'
arch=('x86_64')
url='https://github.com/qarmin/czkawka'
@@ -15,18 +15,18 @@ provides=('czkawka-gui')
conflicts=('czkawka-gui')
depends=('gtk4')
makedepends=('gendesk')
-source=("${pkgname}-${pkgver}::https://github.com/qarmin/czkawka/releases/download/${pkgver}/linux_czkawka_gui_libraw_heif"
- "LICENSE::https://github.com/qarmin/czkawka/raw/${pkgver}/czkawka_gui/LICENSE"
- "czkawka-gui.png")
+source=("${pkgname}-${pkgver}::https://github.com/qarmin/czkawka/releases/download/${pkgver}/linux_${pkgname%-gui-bin}_gui_libraw_heif"
+ "LICENSE-${pkgver}::https://github.com/qarmin/czkawka/raw/${pkgver}/${pkgname%-gui-bin}_gui/LICENSE"
+ "${pkgname}-${pkgver}.png::https://raw.githubusercontent.com/qarmin/czkawka/${pkgver}/${pkgname%-gui-bin}_gui/icons/icon_about.png")
sha256sums=('184f049d040d93a9b16a96c2e6c53a1b17e8590c5dc03a7f6bdb36d3b75f09fb'
'de1d794af7529bc9abb6a1aef6ec2af21fa2bfa4284742144bc30246005b4212'
- '1614565bc6f143b4bb4fc80c71cb1fe0b2ba2719037046719d5a3a89c3f5905e')
+ 'c727bb66ebf6114296a93384af8c2eaeb19eab06482cdd3176155f8f8eef501f')
package() {
install -Dm755 ${pkgname}-${pkgver} "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 ${pkgname%-bin}.png -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 LICENSE-${pkgver} "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE"
+ install -Dm644 ${pkgname}-${pkgver}.png "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
gendesk -f -n --pkgname "${pkgname%-bin}" \
--pkgdesc "$pkgdesc" \
--name "Czkawka" \