summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-07-06 20:47:43 +0800
committerChocobo12023-07-06 20:55:27 +0800
commit1ace6ee17f590ed1045e5a54e22df710e0788185 (patch)
tree3fd2078a095a763ad09a1c3ce246218aacda4fce /PKGBUILD
downloadaur-d2-git.tar.gz
newpkg: d2-git 0.5.1.r147.gce9383577-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b3b641f6ca7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=d2-git
+pkgver=0.5.1.r147.gce9383577
+pkgrel=1
+pkgdesc="A modern diagram scripting language that turns text to diagrams"
+arch=('i686' 'x86_64')
+url="https://d2lang.com/"
+license=('MPL2')
+depends=('glibc')
+makedepends=('git' 'go')
+provides=("d2=$pkgver")
+conflicts=('d2')
+source=("git+https://github.com/terrastruct/d2.git")
+sha256sums=('SKIP')
+
+
+export CGO_CPPFLAGS="${CPPFLAGS}"
+export CGO_CFLAGS="${CFLAGS}"
+export CGO_CXXFLAGS="${CXXFLAGS}"
+export CGO_LDFLAGS="${LDFLAGS}"
+export GOFLAGS="-buildmode=pie -ldflags=-linkmode=external -trimpath -mod=readonly -modcacherw"
+
+pkgver() {
+ cd "d2"
+
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
+}
+
+build() {
+ cd "d2"
+
+ go build \
+ ./...
+}
+
+check() {
+ cd "d2"
+
+ #go test \
+ # ./...
+}
+
+package() {
+ cd "d2"
+
+ GOBIN="$pkgdir/usr/bin" \
+ go install ./
+
+ install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/d2"
+ cp -r "docs" "$pkgdir/usr/share/doc/d2"
+
+ install -Dm644 "ci/release/template/man/d2.1" -t "$pkgdir/usr/share/man/man1"
+}