summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWren Baxter2024-03-25 15:03:35 -0400
committerWren Baxter2024-03-25 15:03:35 -0400
commit2c9c915d5604a3f8944ff2569dee82ffb048ce7c (patch)
treef67d5e7a554962c32c1113b4773f35461657c36f /PKGBUILD
parentbab5ed47d7bae9487ddfe8a12781cd2e33cf2aca (diff)
downloadaur-d80-star-db-astap.tar.gz
use sourceforge instead of google drive
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d827488d8e8..2beacc7d670f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,28 @@
# Maintainer: Wren Baxter <aur [at] wren.dev>
pkgname=d80-star-db-astap
-pkgver=2023.03.30
+pkgver=2023.09.29
pkgrel=1
pkgdesc="D80 star database for 10>FOV>0.15 degrees. Size 1.2GB"
arch=('any')
url="https://www.hnsky.org/astap.htm"
license=('LGPL3')
-source=('sha256.chk')
-md5sums=('SKIP')
+source=('d80.deb::https://sourceforge.net/projects/astap-program/files/star_databases/d80_star_database.deb/download')
+md5sums=('1d0683cbc0d0330df03378fab9d899bf')
optdepends=('astap-bin: binary GTk version'
'astap-bin-qt5: binary Qt version'
'astap: sourced Qt version'
'astap-cli: CLI version'
'hnsky-hg: planetarium program, hg-version'
'hnsky-bin: planetarium program, bin-version')
-makedepends=('gdown' 'unzip')
-# gdown is a helper python script to pull large files from google drive,
-# which have a "this file is too big to be scanned for viruses" warning before downloading
prepare() {
- gdown "https://drive.google.com/uc?id=1HJZQU7BXHc-OvS0BNi_b3Cu8ARy2px2K" -O d80.zip
- # WARNING: the hash in sha256.chk is from google's API, not the developer himself
- # there is a chance, however small, that the file was modified in transit to google drive
- # https://webapps.stackexchange.com/questions/39502/size-and-md5-hash-of-files-on-google-drive
- sha256sum -c sha256.chk
+ tar -xf data.tar.xz
}
package() {
- echo "Unzipping archive..."
- mkdir -p "${pkgdir}"/opt/astap
- unzip -q d80.zip -d "${pkgdir}"/opt/astap
+ mkdir -p "${pkgdir}"/opt
+ cp -r "${srcdir}/opt/astap" "${pkgdir}"/opt
chmod 755 -R "${pkgdir}"
chmod 644 "${pkgdir}"/opt/astap/*
}