summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Pompili2024-04-07 19:56:37 +0200
committerMarco Pompili2024-04-07 19:56:37 +0200
commit9b78d7b8e22f42b60583e8fa24745b89b6c3d4a1 (patch)
tree3a040d6835d8a1d27d951c4a995bd4f54b6993a2 /PKGBUILD
downloadaur-daphne-bin.tar.gz
initial commit, migrated from daphne
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f7c1f0c8a2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Marco Pompili [ marcs (dot) pompili (at) gmail (dot) com ]
+
+_pkgname=daphne
+pkgname=${_pkgname}-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="A command-line multiple arcade laserdisc emulator."
+url="http://www.daphne-emu.com/"
+license=('GPL')
+arch=('i686' 'x86_64')
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-glew' 'lib32-sdl_mixer' 'lib32-zlib' 'lib32-gcc-libs' 'lib32-libxmu')
+ else
+ depends=('glew' 'sdl_mixer' 'zlib' 'gcc-libs' 'libxmu')
+ fi
+source=("http://www.daphne-emu.com/download/${_pkgname}-${pkgver}beta-linux.tar.gz" \
+ daphne.sh \
+ roms.tar.gz)
+sha256sums=('924eb8e20362574b2d2be2e09ca8022c7fbd2711bca7914dda9bbdce4f3ea5ac'
+ 'a44c2c6d3aa44ce88110fd24b7bb390070feb97664c076a75a26fb435d16eb9d'
+ '1f98cff4b8688b4fb7f2fa73ac650b5686a4d6ecf73edaa30722ae5a92135e54')
+
+package()
+{
+ # Install everything in /usr/share
+ cd ${srcdir}/${_pkgname}
+
+ install -Dm755 ${srcdir}/daphne.sh ${pkgdir}/usr/bin/${_pkgname}
+ install -Dm755 ${_pkgname} ${pkgdir}/usr/share/${pkgname}/${pkgname}
+ install -m644 libvldp2.so ${pkgdir}/usr/share/${pkgname}/libvldp2.so
+
+ mkdir ${pkgdir}/usr/lib
+
+ install -m644 ${srcdir}/${_pkgname}/lib/libGLEW.so.1.3 ${pkgdir}/usr/lib/
+ install -d ${pkgdir}/usr/share/${pkgname}/{images,pics,roms/cputest,sound}
+ install -m644 images/*.jpg ${pkgdir}/usr/share/${pkgname}/images/
+ install -m644 pics/* ${pkgdir}/usr/share/${pkgname}/pics/
+ install -m644 ${srcdir}/roms/cputest/* ${pkgdir}/usr/share/${pkgname}/roms/cputest/
+ install -m644 sound/* ${pkgdir}/usr/share/${pkgname}/sound/
+}