summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAttila Fidan2024-05-11 09:32:25 +0000
committerAttila Fidan2024-05-11 09:32:25 +0000
commit57afbffc68d3007acd4259214c43a54f24275e38 (patch)
tree48e6e98b808a68fc381ea8501d3fdbe32f1bb8f0 /PKGBUILD
parent5e9c5abb12616c7a0d6eece10b1a4903746455b6 (diff)
downloadaur-dav1d-git.tar.gz
updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 24 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fbe2ff10915..9b656347086f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,44 @@
-# Maintainer: AtticFinder65536 <atticventilation-aur@protonmail.com>
+# Maintainer: Attila Fidan <archlinux-buildsystem@print0.net>
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
pkgbase="dav1d-git"
-pkgname=(dav1d-git dav1d-doc-git)
-_gitname=${pkgname%-git}
-pkgver=1.3.0.r3.g47107e3
-pkgrel=3
+_gitname=${pkgbase%-git}
+pkgname=(
+ dav1d-git
+ dav1d-doc-git
+)
+pkgver=1.4.1.r29.g37d5243
+pkgrel=1
pkgdesc="AV1 cross-platform decoder focused on speed and correctness"
url="https://code.videolan.org/videolan/dav1d"
-license=(BSD)
-arch=(aarch64 armv7h x86_64)
+license=(BSD-2-Clause)
+arch=(x86_64)
makedepends=(
doxygen
git
graphviz
- libplacebo
meson
nasm
ninja
- sdl2
vulkan-headers
xxhash
)
-source=("git+$url.git"
- "git+$url-test-data.git")
-b2sums=(SKIP
- SKIP)
+source=(
+ "git+$url.git"
+ "git+$url-test-data.git"
+)
+b2sums=(
+ SKIP
+ SKIP
+)
prepare() {
cd "$_gitname"
- ln -s "$srcdir/dav1d-test-data" tests/dav1d-test-data
+ ln -fs "$srcdir/dav1d-test-data" tests/dav1d-test-data
}
pkgver() {
@@ -43,25 +48,21 @@ pkgver() {
build() {
meson setup --prefix=/usr --buildtype=plain \
+ -Dtestdata_tests=true \
-Denable_docs=true \
- -Denable_examples=true \
"$_gitname" build
ninja -C build all doc/html
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package_dav1d-git() {
depends=(glibc)
provides=(libdav1d.so dav1d)
conflicts=(dav1d)
- optdepends=(
- "dav1d-doc-git: HTML documentation"
- "libplacebo: for the dav1dplay example"
- "sdl2: for the dav1dplay example"
- )
+ optdepends=("dav1d-doc-git: HTML documentation")
meson install -C build --destdir "$pkgdir"
@@ -71,9 +72,10 @@ package_dav1d-git() {
}
package_dav1d-doc-git() {
- pkgdesc+=" (documentation)"
+ arch=(any)
provides=(dav1d-doc)
conflicts=(dav1d-doc)
+ pkgdesc+=" (documentation)"
install -d "${pkgdir}/usr/share/doc/${pkgbase}"
cp -r build/doc/html -t "${pkgdir}/usr/share/doc/$pkgbase"