summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSlashbunny2021-05-30 11:31:18 -0400
committerSlashbunny2021-05-30 11:31:18 -0400
commit15f4f4109b8954e6475a3a41b423802e7e17d03e (patch)
treeb3c6d916d51912fe8222c72e88dd2d6ded9f2f55 /PKGBUILD
parent60e7dad3afe76333353d6a2607701db23ae5a5ea (diff)
downloadaur-davtools.tar.gz
Modernize PKGBUILD, but code still needs a patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64bad3530d12..77d449355a82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@ pkgname=davtools
pkgver=1.2.0
pkgrel=3
pkgdesc="Disk Allocation Viewer(DAV) tools for Linux that can obtain the state of fragmentation on disk and visualize it."
-url="http://sourceforge.net/projects/davtools/"
-license="GPL"
+url="https://sourceforge.net/projects/davtools/"
+license=('GPL')
arch=('i686' 'x86_64')
depends=('gtk2')
makedepends=('e2fsprogs')
install=
-source=("http://downloads.sourceforge.net/project/davtools/davtools/Release 1.2.0/davl-${pkgver}.tar.bz2")
-md5sums=('2c58b1f484b0197903f4cf4ee1fc3464')
+source=("https://downloads.sourceforge.net/project/davtools/davtools/Release 1.2.0/davl-${pkgver}.tar.bz2")
+sha512sums=('7d5a663175eed45ee0921934dde8f747f4549f7f5d3f2f76041305ef4823525afad8a57f201ee30c7c0ab74795e7b6035bfa285da98c74bc809f84fcd1c44044')
build() {
cd $srcdir/davl-$pkgver
@@ -19,6 +19,11 @@ build() {
/bin/sed -i "s:/usr/local/:$pkgdir/usr/:" path_list
/bin/sed -i "s:/lib/modules/:$pkgdir/lib/modules/:" path_list
- make || return 1
+ make
+}
+
+package() {
+ cd $srcdir/davl-$pkgver
+
make DESTDIR=$pkgdir install
}