summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDenton Liu2022-10-24 02:45:56 -0700
committerDenton Liu2023-05-07 19:58:49 -0700
commite60bca0edaf344fad5686da94ac3bc2c2885b597 (patch)
treea7de9f8c5f93386a4338a81eaa38ea4049533c83 /PKGBUILD
parentbe86f31b4972c5e94da2b073042cc6bc3b0f0e2c (diff)
downloadaur-ddclient-git.tar.gz
PKGBUILD: fix generated package file
Since we're overriding $pkgname, the generated output filename currently is `ddclient-v3.10.0.r0.g3e2cb0a-1-any.pkg.tar.zst`. This is incorrect because we lost the `-git` suffix. Ensure that the $pkgname is not overridden by the end of package(). This is cherry-picked from d6cf1cd (PKGBUILD: fix generated package file, 2022-10-24) because I've made the same mistake twice. Reported-by: jahway603 <jahway603@protonmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcdf594acb25..5b6d7c83bbbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=ddclient-git
_gitname="${pkgname%-git}"
pkgver=v3.10.0.r48.g841ffcb
-pkgrel=1
+pkgrel=2
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services"
url="https://github.com/ddclient/ddclient"
arch=('any')
@@ -47,6 +47,7 @@ check() {
package() {
# hack so that we can merge in changes from upstream without changing all the
# $pkgname to $_gitname
+ (
pkgname="$_gitname"
cd ${pkgname}
@@ -59,4 +60,6 @@ package() {
install -Dm644 README.md "$pkgdir"/usr/share/doc/ddclient/README.md
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
+
+ )
}