summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-09-23 13:00:35 +0200
committerFabioLolix2023-09-23 13:00:35 +0200
commit66fb45d629899df6431e88f75e78333b5dc6f0db (patch)
tree9fc869d1eb22c9d7d1b9c5826101b886b45d674f /PKGBUILD
downloadaur-deadbeef-plugin-replaygain-scan-git.tar.gz
upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc338930e960
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Peter Lamby <peterlamby@web.de>
+
+pkgname=deadbeef-plugin-replaygain-scan-git
+pkgver=r15.64400aa
+pkgrel=1
+pkgdesc="libEBUR128-based ReplayGain scanner plugin for the DeaDBeeF audio player"
+arch=(x86_64)
+url="https://github.com/Soukyuu/ddb_misc_replaygain_scan"
+license=(MIT)
+depends=(deadbeef)
+makedepends=(git gtk2 gtk3)
+provides=(deadbeef-plugin-replaygain-scan)
+conflicts=(deadbeef-plugin-replaygain-scan deadbeef-replaygain-scan)
+replaces=(deadbeef-replaygain-scan)
+source=("deadbeef-plugin-replaygain-scan::git+https://github.com/Soukyuu/ddb_misc_replaygain_scan.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd deadbeef-plugin-replaygain-scan
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd deadbeef-plugin-replaygain-scan
+ make
+}
+
+package() {
+ cd deadbeef-plugin-replaygain-scan
+ install -dm755 "$pkgdir/usr/lib/deadbeef"
+ cp ddb*.so "$pkgdir/usr/lib/deadbeef"
+ install -D COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}