summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormaz-12015-10-07 23:33:44 +0800
committermaz-12015-10-07 23:33:44 +0800
commit95bf0cae2f21d6bdda0ecc05cd163c3c08946b09 (patch)
treefead29549d0c0ae6067d4bc7dc833969c1416118 /PKGBUILD
downloadaur-deadbeef-replaygain-scan-git.tar.gz
initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf9af1db32d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Peter Lamby <peterlamby@web.de>
+pkgname=deadbeef-replaygain-scan-git
+_gitname=ddb_misc_replaygain_scan
+pkgver=10.154527e
+pkgrel=1
+pkgdesc="Replay scan control plugin for DeadBeeF music player."
+arch=('i686' 'x86_64')
+url="https://bitbucket.org/Lithopsian/deadbeef-opus"
+license=('GPL2')
+provides=(deadbeef-replaygain-scan)
+conflicts=(deadbeef-replaygain-scan)
+depends=('deadbeef')
+source=('git+https://github.com/Soukyuu/ddb_misc_replaygain_scan.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+
+build() {
+ cd "${srcdir}/$_gitname"
+ make
+}
+
+package() {
+ cd "${srcdir}/$_gitname"
+ install -dm 755 "$pkgdir/usr/lib/deadbeef"
+ cp ddb*.so "$pkgdir/usr/lib/deadbeef"
+}