summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgit user2023-11-28 15:49:27 +0100
committergit user2023-11-28 15:49:27 +0100
commit979c4fade4a457576fe1c5c43b3911ed8650fab2 (patch)
tree2acabbf163988d59b95de7fce9acf6ebadbd65a8 /PKGBUILD
downloadaur-dec2hex.tar.gz
Initial Commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6da08628f533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: dreieck
+
+_pkgname=dec2hex
+pkgname="${_pkgname}"
+pkgver=20231128.01
+pkgrel=1
+pkgdesc="Converts decimal numbers to hexadecimal numbers using only sh."
+url="https://aur.archlinux.org/packages/dec2hex"
+license=(
+ 'GPL3'
+)
+arch=(
+ "any"
+)
+depends=(
+ 'sh'
+)
+optdepends=(
+ "hex2dec: To convert the other way round: From hexadecimal to decimal."
+)
+makedepends=()
+provides=()
+conflicts=()
+source=(
+ "dec2hex"
+)
+sha256sums=(
+ 'b2145ccc5f2d973dc1ff9a7d36b58970032c92e0b8174f05f72ea5ad0e1f4858'
+)
+
+pkgver() {
+ printf '%s' "$("${srcdir}/dec2hex" --version)"
+}
+
+package() {
+ install -Dvm755 "${srcdir}/dec2hex" "${pkgdir}/usr/bin/dec2hex"
+}