summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFadeMind2015-06-08 12:07:54 +0200
committerFadeMind2015-06-08 12:07:54 +0200
commit659509da7f8c49cecf65e03a4472c069896f6fd4 (patch)
tree9758a4ddbca26de07946e00df0f9ef4e88124f03 /PKGBUILD
downloadaur-declarative-plasmoids.tar.gz
4.10.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..430001131b9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=declarative-plasmoids
+pkgver=4.10.5
+pkgrel=1
+pkgdesc="A set of plasmoids (QML) for Plasma Active"
+arch=('any')
+url='http://plasma-active.org/'
+license=('LGPL')
+depends=('kdelibs')
+makedepends=('cmake' 'automoc4')
+groups=('plasma-active')
+install=${pkgname}.install
+source=("http://download.kde.org/stable/active/4.0/src/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('b5cbb735b5537c210258ad6f68883c848b7c95bcb4b90eb479284697847cfb8d')
+
+build() {
+ cd "${srcdir}"
+ mkdir build
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="${pkgdir}" install
+}