summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2023-07-03 11:40:14 -0400
committerDavid Parrish2023-07-03 11:40:14 -0400
commit845219d9a5bf84e5ed2da7e36136e086684918aa (patch)
treea4cba4ac231603f00c8098dbfb730d151691529a /PKGBUILD
parent95b315caf7fb35fe34489a9a6f4f39a8fbe9c749 (diff)
downloadaur-decompose-git.tar.gz
Update how submodule is setup and add git as a dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1babcf573ba3..bbcec2c461ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
pkgname=decompose-git
-pkgver=r38.bcb0046
+pkgver=r95.c3950ba
pkgrel=1
pkgdesc="Development Environment Compose - templating framework to help \
developers easily create and switch environments"
@@ -9,7 +9,7 @@ arch=('i686' 'x86_64')
url="https://github.com/dmp1ce/decompose"
license=('custom')
depends=('bash' 'bash-completion')
-makedepends=('txt2man')
+makedepends=('txt2man' 'git')
source=("${pkgname}::git+https://github.com/dmp1ce/decompose.git"
"${pkgname}-mo::git+https://github.com/tests-always-included/mo.git")
sha256sums=("SKIP" "SKIP")
@@ -22,8 +22,9 @@ pkgver() {
prepare() {
# Put 'mo' submodule into the correct location
cd "$pkgname"
- git config submodule.mo.url "$srcdir/${pkgname}-mo"
- git submodule update
+ git submodule init
+ git config submodule.libs/mo.url "$srcdir/${pkgname}-mo"
+ git -c protocol.file.allow=always submodule update
}
build() {