summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCork2020-01-29 18:49:05 +0100
committerCork2020-01-29 18:49:05 +0100
commit0a89aeed5e2cf20555d247237ba5e4f2903f05ec (patch)
treed85dccc59083f825b16f185fdd8c96b39e992f74 /PKGBUILD
downloadaur-dejsonlz4-git.tar.gz
First version of dejsonlz4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c4578f1047f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=dejsonlz4-git
+pkgver=9.c4305b8
+pkgrel=1
+pkgdesc='Decompress Mozilla Firefox bookmarks backup files'
+arch=('x86_64')
+url='https://github.com/avih/dejsonlz4'
+license=('other')
+depends=()
+makedepends=()
+source=("${pkgname}::git+https://github.com/avih/dejsonlz4")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ gcc -Wall -o dejsonlz4 src/dejsonlz4.c src/lz4.c
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -D "dejsonlz4" "$pkgdir/usr/bin/dejsonlz4"
+}
+