summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMads Mogensen2021-01-16 17:15:34 +0100
committerMads Mogensen2021-01-16 17:15:34 +0100
commit1c2e39bc035003744191c331acc3acb685568110 (patch)
tree89d3d9c68bd4577f4720dc07207908a9146b0b48 /PKGBUILD
downloadaur-demoinfo.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d23923609bc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mads Mogensen <mads256h at gmail dot com>
+
+pkgname=demoinfo
+pkgver=1.1
+pkgrel=1
+pkgdesc="Displays info about a source engine demo file."
+arch=('any')
+url="https://github.com/mads256h/${pkgname}"
+license=('GPL3')
+makedepends=('cmake')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mads256h/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('081e20b230a46b0371e6aef3e528a7320ad71b7b9463c5ffc5e0f7b1875e3bea')
+
+build() {
+ # Project does not support in-source builds
+ mkdir "${srcdir}/build"
+
+ pushd "${srcdir}/build"
+
+ # Configure project
+ cmake "${srcdir}/${pkgname}-${pkgver}" -DCMAKE_BUILD_TYPE=MinSizeRel
+
+ # Build project
+ cmake --build . --config MinSizeRel
+
+ popd
+}
+
+package() {
+ # Install the program
+ install -Dm755 "${srcdir}/build/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}