summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2021-03-10 04:54:41 +0100
committerMichal Wojdyla2021-03-10 04:54:41 +0100
commit612c4260988e741a810eabc7cc0cfd6ab5c9e857 (patch)
tree0ceb1ff8d5d123a5df4b1774b6d8edde8a7b88b9 /PKGBUILD
parenta7fb88e47d0982ab6518f7d06824014034b8ee8a (diff)
downloadaur-dep.tar.gz
fix build for real this time
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92ce3c897be2..b29b581c88be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=dep
pkgver=0.5.4
-pkgrel=6
+pkgrel=7
pkgdesc="Deprecated Go dependency management tool"
arch=('x86_64')
url='https://golang.github.io/dep/'
license=('BSD')
-makedepends=('gcc-go' 'git') # build fails with `go` if you know better solution let me know in comments
+makedepends=('go' 'git')
optdepends=('git: fetch git sources')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/golang/dep/archive/v${pkgver}.tar.gz")
sha256sums=('929c8f759838f98323211ba408a831ea80d93b75beda8584b6d950f393a3298a')
@@ -25,6 +25,7 @@ build(){
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
+ export GO111MODULE=off
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
go install ./cmd/...
}