summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCullen2020-09-16 09:41:38 -0400
committerCullen2020-09-16 09:41:38 -0400
commit5a2f374cef4fde10b8078dcf5735d31f30cd0ed9 (patch)
tree5ecc087306ab35b0c140a59158b95804c0d0b509 /PKGBUILD
parentf8a5ddb3bca611a644d64aab653977ec8f4fd774 (diff)
downloadaur-desknamer-git.tar.gz
Proper install location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7204bbc9ed7..0820b8dd7067 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname='desknamer'
pkgname="${_pkgname}-git"
-pkgver=r41.c81f631
-pkgrel=2
+pkgver=r48.c130da0
+pkgrel=3
pkgdesc='automatically rename bspwm desktops based on applications inside'
arch=('any')
url="https://gitlab.com/jallbrit/${_pkgname}"
@@ -21,5 +21,9 @@ pkgver() {
package() {
cd "${srcdir}/${_pkgname}"
- make install
+ install -Dm 755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ mkdir -p ~/.config/desknamer
+ cp -n desknamer.json ~/.config/desknamer/
+ touch ~/.config/desknamer/monitor.blacklist ~/.config/desknamer/desktop.blacklist
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${_pkgname}"
}