summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhorsicq2022-09-04 19:33:21 +0200
committerhorsicq2022-09-04 19:33:21 +0200
commitefafcbd73c9c0b05246de3e0768569e6396d2489 (patch)
tree468cfd280b7d64a56e4ff871cb4b3003a2dbb079 /PKGBUILD
parent0f1470663a71d278afe5f0a881b80ab84100c66c (diff)
downloadaur-detect-it-easy-git.tar.gz
pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df633c01916c..809a9e066dd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,6 +44,11 @@ _color="\e[33m"
_bold='\e[1m'
_prefix=" ${_bold}${_color}==>${_stop} "
+pkgver() {
+ cd "$_srcname" || return
+ printf "%s" "$(git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
prepare() {
cd "$srcdir/$_srcname"
git submodule update --init --recursive