summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSenya2020-09-13 13:17:09 +0300
committerSenya2020-09-13 13:23:51 +0300
commitdd1332e23c9d9e530786b212582ad5d2e9cc30b1 (patch)
tree78056612ebba6360e94f6f0e6e01c5ea86cfc253 /PKGBUILD
parent3ecc69a03cd44d301520335f41bd1b309656d605 (diff)
downloadaur-devdocsgjs-git.tar.gz
Build package for devdocsgjs based on the existing devdocs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 29 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2efc8186b91f..e8f4be375482 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,32 @@
-# Maintainer: Jonian Guveli <https://github.com/jonian/>
-pkgname=devdocs-git
-pkgver=r1033.ddf87bb
-pkgrel=2
-pkgdesc="API Documentation Browser"
+# Maintainer: Senya <senya@riseup.net>
+# Contributor: Jonian Guveli <https://github.com/jonian/>
+pkgname=devdocsgjs-git
+pkgver=r2928.ac8ae363
+pkgrel=1
+pkgdesc="API Documentation Browser (with GJS/GIR support)"
arch=("any")
-url="http://devdocs.io"
+url="https://gitlab.gnome.org/GNOME/devdocsgjs"
license=("MPL")
depends=("ruby" "ruby-bundler" "curl" "nodejs" "coffee-script")
makedepends=("git")
provides=("devdocs-git")
-source=("$pkgname::git+https://github.com/Thibaut/devdocs" "devdocs-server.sh" "devdocs-cli.sh" "devdocs.service")
-md5sums=("SKIP" "SKIP" "SKIP" "SKIP")
+source=("$pkgname::git+https://gitlab.gnome.org/GNOME/devdocsgjs.git#branch=gnome"
+ "devdocs-server.sh"
+ "devdocs-cli.sh"
+ "devdocs.service"
+ "0001-Don-t-require-pry-by-default.patch")
+md5sums=('SKIP'
+ '6f2d514aa412c9b4d0165d35aaa48544'
+ 'd4a2ceec03f265cc60f3091b30eced5c'
+ '2ef3b5bc9519e6929355d49063c1132c'
+ 'ef9bece544b2f2e713e54479257d4c82')
+
+install=devdocsgjs-git.install
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -p1 --forward --strip=1 --input="${srcdir}/0001-Don-t-require-pry-by-default.patch"
+}
pkgver() {
cd "$srcdir/$pkgname"
@@ -30,10 +46,10 @@ package() {
cp "$srcdir/devdocs-server.sh" "$pkgdir/opt/$pkgname/devdocs-server.sh"
cp "$srcdir/devdocs-cli.sh" "$pkgdir/opt/$pkgname/devdocs-cli.sh"
- cp "$srcdir/devdocs.service" "$pkgdir/usr/lib/systemd/system/devdocs.service"
+ cp "$srcdir/devdocs.service" "$pkgdir/usr/lib/systemd/system/devdocsgjs.service"
- ln -s "/opt/$pkgname/devdocs-server.sh" "$pkgdir/usr/bin/devdocs-server"
- ln -s "/opt/$pkgname/devdocs-cli.sh" "$pkgdir/usr/bin/devdocs-cli"
+ ln -s "/opt/$pkgname/devdocs-server.sh" "$pkgdir/usr/bin/devdocsgjs-server"
+ ln -s "/opt/$pkgname/devdocs-cli.sh" "$pkgdir/usr/bin/devdocsgjs-cli"
mkdir -p "$pkgdir/opt/$pkgname/tmp"
@@ -43,6 +59,6 @@ package() {
chmod -R g+w "$pkgdir/opt/$pkgname/public"
chmod -R g+w "$pkgdir/opt/$pkgname/tmp"
- cd "$pkgdir/opt/$pkgname" && bundle install --path .bundle
- cd "$pkgdir/opt/$pkgname" && bundle exec thor assets:clean && bundle exec thor assets:compile
+ env -iC "$pkgdir/opt/$pkgname" sh -lc "bundle install --path .bundle"
+ env -iC "$pkgdir/opt/$pkgname" sh -lc "bundle exec thor assets:clean && bundle exec thor assets:compile"
}