summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2015-08-15 01:44:35 -0400
committerChris Severance2015-08-15 01:44:35 -0400
commit918e3e55b5be594b2114f4eede7c2dd97d0aa81c (patch)
tree80500b7ca5e3e2b58e749c6ce3a9a343adfaa0bd /PKGBUILD
parentf2abf45a1ee0380ae5a28517bc2539b2f0d64bfb (diff)
downloadaur-918e3e55b5be594b2114f4eede7c2dd97d0aa81c.tar.gz
Smarter installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb30c643e64f..c9e30c6eca06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,8 +23,6 @@
# To clean up you may want to remove the folders /share/ and /etc/init.d/
# Arch Linux does not use these folders though they may have spurious files from
# other misdirected installs.
-# If you have a configuration: mv "/etc/dgrp.backing.store" "/etc/dgrp.backing.store.pacsave"
-# The new Install will pick it up automatically.
# The next section: ... Now onto the real install ...
@@ -100,6 +98,9 @@ makedepends=('linux-headers')
depends=('openssl' 'grep' 'awk' 'systemd')
backup=('etc/dgrp.backing.store')
optdepends=('tcl: digi config manager in X' 'tk: digi config manager in X')
+_verurl='http://www.digi.com/support/includes/drivers?pid=2247&osvid=218'
+_versed='Realport Driver for Linux ver\. \([0-9\.]\+\), tgz version' # used with ^...$
+_veropt='t'
source=("${pkgname}-${pkgver}-81000137_W.tgz::http://ftp1.digi.com/support/driver/81000137_W.tgz" 'drpadmin' 'drpadmin.1' "autorebuild-${pkgname}.sh")
sha256sums=('218c3a873f8623d2e663735efdee384f7dac784327cea9e7211eddce700fe1c8'
'1ab0ccdc361760ae078f9b69f603e99b40849cdf97ad69bb028ad6af27012634'
@@ -293,10 +294,20 @@ done
_geninstall() {
# produce the Install script so it doesn't need to be downloaded separately
# I'm wondering why there isn't a function for this.
-cat > "${install}" << EOF
+cat > "${install}" << EOF # "
# Automatically generated by ${pkgname}-${pkgver} PKGBUILD from Arch Linux AUR
# http://aur.archlinux.org/
+pre_install() {
+ set -u
+ # Ensure that config files don't get lost on reinstall, chiefly from the digi make install to package upgrade
+ # post_install code will rename it back
+ if [ -s '/etc/dgrp.backing.store' -a ! -s '/etc/dgrp.backing.store.pacsave' ]; then
+ mv '/etc/dgrp.backing.store' '/etc/dgrp.backing.store.pacsave'
+ fi
+ set +u
+}
+
post_upgrade() {
set -u
mandb -q