summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorberberman2020-06-21 13:11:04 +0800
committerberberman2020-06-21 13:11:04 +0800
commit9c215d6d277f091fefcc26b5c888b3c9d7dbcd6c (patch)
treed3dfb096647d2a6e7cd8bb1862a9fc7b16629af4 /PKGBUILD
downloadaur-dhall-to-cabal.tar.gz
1.3.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a36e168750e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: berberman <hatsue@typed.icu>
+
+pkgname=dhall-to-cabal
+pkgver=1.3.4.0
+pkgrel=1
+pkgdesc="Compile Dhall expressions to Cabal files"
+arch=('x86_64')
+url="https://github.com/dhall-lang/${pkgname}"
+license=('MIT')
+makedepends=('stack')
+depends=('gmp' 'zlib')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('84692e4202a0908fb667021116a1c2a3b786e6cb5e2d82d5460040eb4ef4b380')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ stack build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ stack --local-bin-path "${pkgdir}/usr/bin/" install
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}